Results 1 to 3 of 3

Thread: Voipo early registration expiration issue, ongoing since approx Nov 2019

  1. #1
    Join Date
    Jul 2010
    Posts
    367

    Default Voipo early registration expiration issue, ongoing since approx Nov 2019

    This issue is back again since around Nov 2019, and persisting as of today, Oct 21, 2020. Almost a year with no solution.

    What is happening is that device registrations are being expired by the Voipo servers about 20 to 30 seconds early.

    Example, if your device registers for 300 seconds (5 minutes), then Voipo will expire the registration at about the 230 second (4.5 minute) mark. So your inbound calls will fail for those final 20 or 30 seconds.

    You can try setting your device to remain registered longer, but 900 seconds (15 minutes) is about the maximum you can get away with, since most routers will close the UDP ports every 15 minutes. You need to keep registering to prevent this.

    At 900 seconds, that is 3.3% failure rate. So 3 out of every 100 inbound calls will fail. Of course, if your device is set to 5 minutes, you'll get 10% failure. And for PBX users, the default registration of 2 minutes will result in a 25% failure rate. None of those rates are acceptable.

    I've had numerous tickets open with Voipo, including direct emails to Tim the owner. However, there seems to be no progress, despite the critical nature of this issue. I only get an occassional response that their developer team is aware of it, and working on it.

    If you want to duplicate the issue, just set your device registration expiration to something fairly short, like 120 seconds (2 minutes). Then log into your voipo control panel to view the device registration. Refresh the page periodically, especially as you get close to the last 30 seconds. You'll see your device disappear for 20 to 30 seconds. Then at the correct registration time, your device will register and appear again.

    Anyway, just feel like I need to post this, since Voipo doesn't mention it on their Twitter issue notification page.

  2. #2
    Join Date
    Feb 2009
    Location
    Houston suburb
    Posts
    251

    Default Re: Voipo early registration expiration issue, ongoing since approx Nov 2019

    Correct.

    You and I have known or dealt with this issue for some time in other threads. Many support tickets. I finally gave up about 2 years ago and took your advice and bought my father a Grandstream HT802. This ATA has an option to "Reregister before expiration" that completely resolves the issue. Older ATAs like Linksys PAP2T, SPA2002 lack this option and exhibit the expiration issue. My Yealink W52/W56 also lacks this option, but by design it automatically reregisters 50% early so it avoids the issue.

    It seems some of the newer SIP devices either have this option or by design automatically reregister early.

    By the way, this issue also occurs on their server for provisioned users (sip-central) not just on their BYOD sip/sip7 servers.

    This still doesn't absolve Voipo from fixing the servers on their end. I just finally raised the white flag....
    Last edited by tritch; 10-22-2020 at 12:00 AM.

  3. #3
    Join Date
    Jul 2010
    Posts
    367

    Default Re: Voipo early registration expiration issue, ongoing since approx Nov 2019

    Unfortunately, I have a lot of clients using devices that don't have an early re-register feature. So they are missing inbound calls on an ongoing basis.

    Voipo seems out of ideas. When I ask for updates, they act like they are re-opening the ticket, or they don't respond at all. Either way, it seems they haven't taken it very seriously.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •