Results 1 to 6 of 6

Thread: Calls from ASTERISK

  1. #1
    Join Date
    Jan 2011
    Posts
    25

    Default Calls from ASTERISK

    I'm a new user and have been receiving calls about once a day without CID, but with CNAM of ASTERISK. These are not real calls and there is no caller or record in the call detail register. My configuration is:

    HT502 Port 1 on Voipo, Port 2 on VoIP.ms. Only port 1 receives these calls
    I'm behind a firewall router with ports 5000-6500 forwarded to the IP of the ATA
    Using port SIP port 5060 for port 1 and 5062 for port 2. Just changed the HT502 to use random ports.

    Only the VoiPo line receives the calls the VoIP.ms line has not been affected. I have two services so that I have redundant operation, having learned to not put all of the service in one basket.
    Any suggestions on how to stop these random ASTERISK calls?

  2. #2
    Join Date
    Feb 2009
    Location
    Houston suburb
    Posts
    213

    Default Re: Calls from ASTERISK

    Most likely hackers scanning open SIP ports. It appears you are a BYOD user since you are using line 2 with another provider. If so, I would simply change your Voipo sip port of 5060 to something non-standard like 5078.

  3. #3
    Join Date
    Feb 2010
    Posts
    235

    Default Re: Calls from ASTERISK

    My incoming rings marked Asterix stopped when VoIPo said they moved the ATA to non-standard ports. I changed nothing in my router, and I don't do port-forwarding. The router does have ALG settings for SIP and RTSP.

  4. #4
    Join Date
    Jan 2011
    Posts
    25

    Default Re: Calls from ASTERISK

    Thanks for the comments. It would appear that the "hackers" are only looking for the first standard port 5060 and not looking for 5062. That may be why only Voipo is affected as line 1. I will take your suggestions and see if that works.

    I've used voip with Quantumvoice for over three years and never had this problem using the standard port configuration. I may just switch my Voipo line to #2 and my voip.ms line to #1 to see if the problem follows the line or service. An interesting experiment.

  5. #5
    Join Date
    Jan 2009
    Posts
    225

    Default Re: Calls from ASTERISK

    ...or set 'Check SIP User ID for incoming INVITE:' and/or 'Allow Incoming SIP Messages from SIP Proxy Only:' to Yes under the FXS Port tab

  6. #6
    Join Date
    Jan 2011
    Posts
    25

    Default Re: Calls from ASTERISK

    The "Use random ports" seems to have solved the problem. I restricted the SIP servers as an additional barrier. No more ASTERISK calls. Thanks to all for the help in identifying the issues and proposing solutions.

    I am currently happy with my HT502 BYOD config, including a 7-10-11 dial plan, NAT keep alive, random ports, and SIP restrictions.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •